sublime插件OmniMarkupPreviewer出现buffer_id(28) is not valid错误解决办法

该文章由 leevare 发布于 ,归类于 Sublime

sublime的插件OmniMarkupPreviewer提供markdown编辑时实时预览功能,但是今天在打开预览时出现如下错误:'buffer_id(28) is not valid (closed or unsupported file format)',如下图

image

查询得知解决办法如下:

Quick Fix 1: Remove Strikethrough Extension

Sublime Text > Preferences > Package Settings > OmniMarkupPreviewer > Settings - User粘贴如下代码

{
    "renderer_options-MarkdownRenderer": {
        "extensions": ["tables", "fenced_code", "codehilite"]
    }
}

Quick Fix 2: Fix the Strikethrough Extension (if you need it)

Find the python-markdown sublime package.

On the Mac: subl "/Users/<username>/Library/Application Support/Sublime Text 3/Packages/OmniMarkupPreviewer/OmniMarkupLib/Renderers/libs/mdx_strikeout.py"

Replace the makeExtension() method with the following:

def makeExtension(*args, **kwargs):
    return StrikeoutExtension(*args, **kwargs)

Save, quit and reload Sublime Text.

如果觉得我的文章对您有用,请您随意打赏。您的支持将鼓励我更加努力创作!

相关文章:

说点什么

avatar
300
  Subscribe  
提醒