Module not found: Error: Can’t resolve ‘popper.js’ ….错误解决办法

该文章由 leevare 发布于 ,归类于 Webpack

引入bootstrap后,webpack打包报错

Module not found: Error: Can't resolve 'popper.js' ....

这是因为使用webpack打包bootstrap4的时候,需要手动安装jquerypopper.js

npm install bootstrap@4.0.0-beta -D
npm install jquery -D
npm install popper.js -D

webpack如下配置即可

plugins: [
    ...
      new webpack.ProvidePlugin({
        $: 'jquery',
        jQuery: 'jquery',
        'window.jQuery': 'jquery',
        Popper: ['popper.js', 'default'],            
        ...
      })
    ...
  ]

以上解决方案来自:https://stackoverflow.com/questions/45660672/webpack-fails-to-load-bootstrap-v4-0-0-beta

如果觉得我的文章对您有用,请您随意打赏。您的支持将鼓励我更加努力创作!

相关文章:

说点什么

avatar
300
  Subscribe  
提醒